Quantcast
  1. Sign up now and join over 35,000 northwest gun owners. It's quick, easy, and 100% free!

Wilson Combat/Scattergun mag tube exension help...

Discussion in 'Maintenance & Gunsmithing' started by sealine, Jun 27, 2010.

  1. sealine

    sealine Oregon Well-Known Member

    Messages:
    340
    Likes Received:
    283
    So, I just bought a Wilson Combat mag tube extension for my 870. The tube has a vertical sling clamp on it and for the life of me, I can't figure out how to get it on. The tube cannot be turned due to the sling clamp in the way and the knurled part at the base of the tube doesn't spin freely. What am I missing? Thanks in advance for the help.
     
  2. rufus

    rufus State of Jefferson Well-Known Member

    Messages:
    1,585
    Likes Received:
    930
    I removed the sling clamp on mine, not because of installation problems but rather I did not want a sling on a pump HD shotgun. That sure made it easy to install. :)

    The wilson tube is a quality part, it should be just a matter of thread alignment - with or without the sling clamp.
     
  3. GSB09

    GSB09 Portland Oregon Member

    Messages:
    61
    Likes Received:
    0
    It may just be really heavy parkerizing on the tube. Mine was initially hard to turn also, the parkerizing was built up in the slot where the sling clip fit. You should be able to rotate the clip on the the tube and then spin the mag ext.tube on the gun.
    If that doesn't do it just call the guy's at Wilson they will take care of you.
     
  4. spider

    spider Hillsboro Well-Known Member

    Messages:
    1,278
    Likes Received:
    66
    Wait a minute, did you remove your original sling mount first from the.barrel of your 870?
     
  5. sealine

    sealine Oregon Well-Known Member

    Messages:
    340
    Likes Received:
    283
    There was no original sling mount, but if you're talking about the original mag tupe cap, yeah I removed that.
     
  6. sealine

    sealine Oregon Well-Known Member

    Messages:
    340
    Likes Received:
    283
    I think you were right GSB. I sprayed some lube on the mag tube where the sling mount is at and let it sit overnight. No such luck, the sling mount still would not turn on the tube. I ended up putting the tube in a vise and gave the sling mount a few taps with a plastic tip hammer and that broke it loose. I think it may have been the parkerizing. Thanks for the help.
     
  7. cbzdel

    cbzdel Tacoma, WA Member

    Messages:
    528
    Likes Received:
    8
    i had the same problem with mine, just to much parkerizing on it tube..