NWFA 2.0 Upgrade Issues Thread

Discussion in 'Questions, Problems, & Feedback' started by Joe Link, Jan 9, 2011.

  1. Joe Link

    Joe Link
    Portland, OR
    Well-Known Member Staff Member Lifetime Supporter Bronze Supporter 2015 Volunteer 2016 Volunteer

    Messages:
    6,780
    Likes Received:
    5,988
    So as I mentioned in the Welcome to NWFA 2.0 thread, there are quite a few issues I'll be addressing over the next couple days. I'm going to maintain a list in this thread so each of you will know where we stand with each of these issues, and so you guys can help me identify issues I wasn't aware of. If any of you were having issues with the previous software, now would be a good time to post those in here as well, as we'll now be looking into them.

    "The List"
    - Theme is too 'bright' and difficult to read.
    - Time limit for bumping classified posts does not work.
    - FIXED: Various formatting issues (overlapping images/text).
    - FIXED: Remove classified posts from the What's New button.
    - FIXED: Remove business ratings from front page polls.
    - FIXED: Links within threads are not "distinguishable" from normal text.
    - FIXED: Advanced search defaults to multi-search rather than single search.
    - FIXED: Black pistol next to the URL is missing.
    - FIXED: 404 errors with links from bookmarks and search engines.
    - FIXED: iTrader data is not showing in profiles or on postbit.
    - FIXED: Flash attachment manager will not upload images.
    - FIXED: CMS front page is having a problem with permissions.
    - FIXED: Intermittent Internal Server Errors still present with certain posts/PM's.
    - FIXED: Post icons next to thread listings do not show up (talking, lightbulb, verify in IE)
    - FIXED: Supporting Members, Resource Map, Printable Forms navbar links do not work.
    - FIXED: Supporting Member/Vendor/Staff badges are not being displayed.
    - FIXED: Smiley's do not work.
    - FIXED: Avatars do not work.
    - FIXED: Custom profiles pictures do not work.
     
  2. Sodbuster

    Sodbuster
    Beaverton, OR
    Chief Cook/Bottle Washer Bronze Supporter

    Messages:
    364
    Likes Received:
    140
    Just tried to get into the site. Finally did (after it rejected the old link to the forums). After I logged in, NWFA tried to automatically redirect me to another location.

    Which then resulted in a permissions issue with a blurb about me not having permissions to access the site. What ever that site was.

    Just letting you know.

    Sodbuster

    PS -- new look is good though.
     
  3. Joe Link

    Joe Link
    Portland, OR
    Well-Known Member Staff Member Lifetime Supporter Bronze Supporter 2015 Volunteer 2016 Volunteer

    Messages:
    6,780
    Likes Received:
    5,988
    Thanks for the heads up, did you get it figured out? I imagined people will probably have problems with their cookies since I changed the directory during the upgrade. Clearing cookies and flushing the cache should resolve any issues.
     
  4. Tactical SS

    Tactical SS
    Washington
    Member

    Messages:
    596
    Likes Received:
    19
  5. marty8587

    marty8587
    NE Portland
    Active Member

    Messages:
    833
    Likes Received:
    170
    I get the no permission log on page which tells me I don't have permission and doesn't recognize my user name or password. I also get a page not found when trying to respond to the email notifications.
     
  6. Joe Link

    Joe Link
    Portland, OR
    Well-Known Member Staff Member Lifetime Supporter Bronze Supporter 2015 Volunteer 2016 Volunteer

    Messages:
    6,780
    Likes Received:
    5,988
    Did you guys try clearing your cookies and cache?
     
  7. marty8587

    marty8587
    NE Portland
    Active Member

    Messages:
    833
    Likes Received:
    170
    This one came up from the email link, still couldn't get to the ones sent last night. Joey, get some sleep, it will come together. I have no idea how to clear acookie or cache?
     
    Last edited: Jan 9, 2011
  8. Tactical SS

    Tactical SS
    Washington
    Member

    Messages:
    596
    Likes Received:
    19
    I did. Still no luck.

    In the page permissions, is it set to everyone? I know I ran into some trouble on a forum I run with that. I just set permissions to everyone again, even though it was already set to that, and it cleared right up.

    Oh and yes Joey, if you haven't been to bed yet, go get some sleep. I'm sure we all can manage without having the home page for another day or two. If you need any help, I have some very limited knowledge.
     
  9. no time

    no time
    Roseburg area
    Active Member

    Messages:
    296
    Likes Received:
    64
    I didnt clear cookies or cache, but when my old shortcut directed me into "URL Not Found", I trimmed the "/forum" off the end of the address and that got me to the homepage and the already mentioned login stuff. I then updated my shortcut.

    I suspect a lot of folks are going to lose their way here. Is there a plan to email members to advise them of the changes and lead them back? I'd hate to see any of the membership gone.
     
  10. Will_Power

    Will_Power
    OR via OK
    Active Member

    Messages:
    599
    Likes Received:
    175
    I had the no-permission page flop up as well - I had to visit the main page / root, and then click on forum to get in.

    Also, since the old install was at /forum/ and the new one is /forum.php - and since the old /forum/ is a 404 error, can you guys set up a redirect from /forum/ and point it to /forum.php?
     
  11. Joe Link

    Joe Link
    Portland, OR
    Well-Known Member Staff Member Lifetime Supporter Bronze Supporter 2015 Volunteer 2016 Volunteer

    Messages:
    6,780
    Likes Received:
    5,988
    I verified the permissions problem with the front page, working on that now. I'll also setup a redirect from /forum, good call!
     
  12. receo

    receo
    Sandy, Oregon
    Active Member

    Messages:
    202
    Likes Received:
    116
    First off I am excited about the update and sure it will be a great benefit. I had the before mentioned permission issue on the homepage and cannot access any of the pages under the nwfirearms resources tab. Thanks again and love the site. Get some sleep.

    FYI, iphone4 w safari browser.
     
  13. VW_Factor

    VW_Factor
    Woodburn Oregon
    Active Member

    Messages:
    649
    Likes Received:
    101
    On my first post after the upgrade, it sent me to the accept terms and conditions page again. (The one you usually get after signing up).

    I am unsure if that is working as intended or a bug.
     
  14. nwo

    nwo
    Southern Oregon
    Well-Known Member

    Messages:
    1,610
    Likes Received:
    245
    I am curious as to why everything was changed in the first place?

    I rather liked the "old" format, and was quite 'used' to it. Why change things, and make things seemingly more difficult?
     
  15. Joe Link

    Joe Link
    Portland, OR
    Well-Known Member Staff Member Lifetime Supporter Bronze Supporter 2015 Volunteer 2016 Volunteer

    Messages:
    6,780
    Likes Received:
    5,988
    Requiring everyone to accept the rules is an intended feature. This way we'll have everyone on the same page and nobody can use the excuse that they didn't know what they were doing was wrong ;)
     
  16. marty8587

    marty8587
    NE Portland
    Active Member

    Messages:
    833
    Likes Received:
    170
    I've been accepted!! It took my password and user name, but still told me I was someplace I don't sposed to be. It is working out thanks to the Sleepless One.....
     
  17. VW_Factor

    VW_Factor
    Woodburn Oregon
    Active Member

    Messages:
    649
    Likes Received:
    101
    Good to know Sir.

    :D
     
  18. VW_Factor

    VW_Factor
    Woodburn Oregon
    Active Member

    Messages:
    649
    Likes Received:
    101
    Oh. I cannot send PMs at this point either. Throws a 500 internal server error something or another.

    Edit : Maybe it was just a temporary issue. Seemed to be able to just now send a couple just fine..
     
  19. drew

    drew
    OR
    Well-Known Member

    Messages:
    4,050
    Likes Received:
    971
  20. PhysicsGuy

    PhysicsGuy
    Corvallis, OR
    Resident Science Nut

    Messages:
    4,134
    Likes Received:
    162
    Looks like it doesn't say Im a mod on my posts :D
     

Share This Page